Microsoft Surface Pro 11 Copilot+PC - 13.0" Touch / Ultra 5 / 16GB / 256GB SSD / Win 11 Pro / Business Edition - Black Network Racks 2 • Secure Command Line
USD169.50
USD196.50
Pay in 4 interest-free payments of $42.38 Learn more
Shipping Estimate
USA
- USA
- CAN
- USA
- CAN
Ships within 48 hours · Estimated delivery Oct 5 - Oct 10
Terrace notes
Description
Microsoft Surface Pro 11 Copilot+PC 13.0" Touch Ultra 5 16GB 256GB SSD Win 11 Pro Business Edition Black Network Racks 2 • Secure Command Line 2 • Secure Command Line Interface (CLI) management with SSHv1 SSHv2 • IP Port MAC based access control MIBs • MIB II (RFC1213) • Bridge MIB (RFC1493) • P Q Bridge MIB (RFC2674) • Radius Accounting Client MIB (RFC2620) • Radius Authentication Client MIB (RFC2618) • Remote Ping App Compatible
Exchange/Return Notes
- We offer a 30-day return/exchange service after receiving.
- Final sale items are not eligible for returns or exchanges.
- To process your return/exchange, please contact us at [email protected]
- Please click here for more details>>> Return & Exchange Policy
Discover
Magnesite finds
You may also like
Susan Shaw Water Lily Studs Pumpkin
US$ 37.00
Aqua Collection Ambre Brandy new years
US$ 37.99
Beefeater London Dry Gin Whiskey_Rye
US$ 29.99
Breaker Bourbon Whisky site86
US$ 64.99